NetBeans へ Ruby プラグインのインストール

Posted by muchag | Ruby on Rails | 2012-04-22 (日) 16:45:09

Eclipse ベースの IDE もあるようだけど
どうも NetBeans が主流のようなので、まずはこちらでチャレンジ!

【環境】
[Ruby] 1.9.3-p194
インストール

NetBeans より DL 。
この際、参考サイトに従って「すべて」のヴァージョンを選択。
2012-04-22 現在
NetBeans IDE 7.1.1
netbeans-7.1.1-ml-windows.exe
 

プラグインの入手

http://jruby.org.s3.amazonaws.com/downloads/community-ruby/community-ruby_7_1_preview1.zip
より DL 。
community-ruby_7_1_preview1.zip

適当な場所へ展開。
 

NetBeans へ登録

— ここから引用
そして、NetBeans 7.1を起動して、以下の手順でプラグインをインストールします。

  1. メニューから[ツール]→[プラグイン]を選択
  2. [ダウンロード済み]タブを選択
  3. [プラグインの追加]ボタンをクリック
  4. ZIPファイルを展開したディレクトリの下のupdatesディレクトリにある、すべての.nbmファイルを選択(計25個)
  5. [OK]ボタンをクリック ← [開く] ボタンだった
  6. [インストール]ボタンをクリック
  7. [次へ]ボタンをクリック
  8. [すべてのライセンス契約条件に同意する]をチェック
  9. [インストール]ボタンをクリック
  10. 「次のプラグインは署名されていますが信頼されていません」という警告が出たら[続行]ボタンをクリック
  11. [完了]ボタンをクリック

ここでNetBeansが再起動されます。
— ここまで引用
 

参考サイト

Ruby on Rails with OIAX:NetBeans 7.1にRuby on Railsプラグインをインストールする手順

Ruby on Rails | 2012-04-22 (日) 16:45:09 |

コメントはまだありません »

No comments yet.

RSS feed for comments on this post. TrackBack URI

Leave a comment