PDO -> インストール

Posted by muchag | PHP,困ったTT |
初回投稿:2008-01-07 (月) 23:43:50 | 最終更新:2011-04-17 (日) 19:00:50

PDO(PHP Data Object)は、PHP5 以上で利用可。
PHP5.1 以上では、標準搭載。
よって、利用しようと思ったら、php.ini の編集ですむらしい。

UNIX系の 場合
  1. extension=pdo.so
  2. extension=pdo_mysql.so (この行は、利用するDBにあわせて変更)

 

Windows の場合
  1. extension=php_pdo.dll
  2. extension=php_pdo_mysql.dll (この行は、利用するDBにあわせて変更)

 
もし、PDOのモジュールがインストールされていなければ、シェルコマンドから

  1. %pecl install pdo
  2. %pecl install pdo_mysql (この行は、利用するDBにあわせて変更)

<参考元>
PDOでサクサクDB開発

と、上記サイトにあったのだが・・・
pecl コマンド自体が使えない・・・
さぁ どうする@@

Posted by muchag | PHP,困ったTT |
初回投稿:2008-01-07 (月) 23:43:50 | 最終更新:2011-04-17 (日) 19:00:50

コメントはまだありません »

No comments yet.

RSS feed for comments on this post. TrackBack URI

Leave a comment